• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • As we have now upgraded the main XenForo community, this forum is now being retired. It will remain open in a mostly read only state. Any further feedback, suggestions or bug reports should be posted on the main forum. We will still process the existing bug reports from this forum.

    When we approach a stable release, this forum will become inaccessible. If there is any content you wish to save, please do so before then.

Third party Editor - dragging & dropping multiple files only uploads one

Martok

Well-Known Member
#1
I've tested this several times now and it's the same on each occasion no matter the combination or type of files. If you select multiple files and then drag and drop them into the editor, only the first selected file is uploaded.

Tested in the latest versions of Google Chrome, Firefox and Safari on Mac OS Sierra.
 

Liam W

Active Member
#3
Screen Shot 2016-11-21 at 22.06.24.png


I can confirm this on macOS Sierra Chrome 53. I selected a good 10 images and it only put 1 in.

(I had 20 or so screenshots on my desktop as I was testing a my images widget add-on ;))
 

Martok

Well-Known Member
#4
@Liam W why is your screenshot from an XF1 installation (where drag and drop is working fine) when we're talking about XF2?

Importantly, why are you using Chrome 53 and not 54? Update that browser, now!! :D
 

Liam W

Active Member
#5
@Liam W why is your screenshot from an XF1 installation (where drag and drop is working fine) when we're talking about XF2?
(I had 20 or so screenshots on my desktop as I was testing a my images widget add-on ;))
Importantly, why are you using Chrome 53 and not 54? Update that browser, now!! :D
Because I didn't know 54 was out and Chrome isn't telling me to upgrade ;) That and the fact I rarely close Chrome fully.
 

Mike

XenForo Developer
Staff member
#6
This is roughly how the underlying support within Froala is designed. We may be able to change this by essentially just ripping out the behavior and doing our own thing, though the image dragging support isn't something we want to lose.

This wouldn't really be considered a bug in Froala but a feature/enhancement request, though I will pass it on. Making significant changes here wouldn't be a high priority. At this point, I'm going to leave this open but tag it as third party.
 

Martok

Well-Known Member
#7
This wouldn't really be considered a bug in Froala but a feature/enhancement request, though I will pass it on.
Thanks for this. I hope that Froala consider this for implementation. Typically in Redactor I would select and drag multiple files into the editor to upload them, now I will be forced to use the attach files link.